BlackBerry Z10 USB Port Repair

So I needed to find a way to repair the USB port on my Z10. I had  purchased it used with issues on the port – the previous owner dropped it a lot and the port got damaged – wouldn’t charge properly. So I purchased some ports off eBay and did two things:

  1. Checked for a USB port fix / schematics online.
  2. Used another Z10 with a working port to verify the pinouts.

As it turns out this dude called ABUBABLU did some good repair work on a Z10 before and provided solder points for USB, battery and SIM slot on the Z10. I give all credit to this guy because he’s a very good electronics tech from the other stuff he posted – unfortunately he doesn’t answer back as I’ve emailed him on this issue.

All of the points check out except for one – his schematic diagram has the #4 USB pin as the CRADLE_USB_ID which is what (I guess) starts the USB connection – exists on my model. There may be a difference in the STL100-1/2/3 boards. There is a solder point near the SD card slot on the phone that does not exist on my model – on mine there’s just a row of capacitors (I think they’re caps – so small…..) and I can’t find where that pin should go.

The original posts I found on GSMARENA and others can be found on another site.

I had to run all the lines using IDE cables because all the solder points on the board for the USB port were torn off during removal – they were just that badly damaged (and I don’t have a rework station……) – The phone now charges with no issues, but the USB connection can’t work works occasionally – going to check and see if I can fix that permanently.

I’m not sure which model ABUBABLU took his information from, but my model is different. Here are pics of the ports as I’ve tested and mapped. Most of them are exactly the same as his except one. Hope this helps others with the endeavor. Mine doesn’t work so well due to the fact that I thought the connection went to a capacitor where his was in the picture. His pictures were also low quality so I couldn’t see it well. It was after some checking that I finally found out the models were different and the points not the same. I probably screwed up something, but it happens to help out others. Hopefully someone else will get their things fixed and not go through this issue.  All credits for the original information go to ABUBABLU – kudos.

Picture of full board (WARNING! picture is 10MB)

Z10 - USB MAP - C&TS

 

Close-Up of solder points

Z10 - USB MAP (CLOSE) - C&TS

Comments

comments